Amazon CloudFront Elevated SSL Handshake Failures
Incident Report for Yottaa
Resolved
This issue has been resolved. If you have any questions or concerns, please contact our support team at support@yottaa.com.
Posted 3 months ago. Jun 16, 2017 - 02:56 EDT
Update
AWS has update their status page to the following "Between 1:20 PM and 3:30 PM PDT, we experienced SSL Handshake and BadRequest errors to some CloudFront edge locations. The issue has been resolved and the service is operating normally." Yottaa Real-time analytics dashboards are still catching up with back-filling traffic data. We will update this notice once more information is available.
Posted 3 months ago. Jun 15, 2017 - 19:38 EDT
Update
AWS has posted the following update on their status page: " We have identified the cause of elevated SSL handshake and BadRequest errors from our CloudFront edge locations and continue to work towards resolution."

Yottaa engineers are reporting our Real-time analytic dashboards are catching back up. We will continue to monitor this situation and keep this posting updated as we learn more.
Posted 3 months ago. Jun 15, 2017 - 18:13 EDT
Monitoring
Amazon Web Services (AWS) has notified clients that they are seeing an elevated SSL handshake failures from their worldwide CloudFront edge locations. AWS is posting updates at https://status.aws.amazon.com/. Real-time analytics dashboards may be delayed due to this issue, but will backfill. We are monitoring the situation and will keep this support notice updated as we learn more information.
Posted 3 months ago. Jun 15, 2017 - 17:04 EDT